Unable to connect to MatchX cloud

I’m struggling to get my new MatchX gateway to connect to the cloud. Or even try to connect to anything.

Here’s what has worked:

  • Gateway powers up and issues an SSID. I can connect to this wirelessly using the SN
  • Gateway is able to join my network and get assigned an IP

Here is what isn’t working:

  • Gateway red light remains stubbornly on
  • when I try to register the serial number on MatchX cloud, I get a “board not found” error

Here’s what I’ve tried:

  • multiple restarts of the router and gateway
  • I’ve confirmed that my router is set up for traffic for UDP on ports 1700, 1459 and 1194
  • I’ve tested this successfully using iperf for both incoming and outgoing to a separate iperf server on those ports
  • When I try an iperf test on my MatchX cloud URL (I’m in Australia) I don’t get a response. I’m guessing this is because there is one central point which is then delegated out
    $ iperf -c aux.matchx.io -p 1700 -u
  • I tried using Wireshark to try to see what the Gateway was trying to send to, but I don’t see any activity on that IP apart from the initial network stuff. The light just stays red
  • I’ve tried using just the LAN connection rather than Wifi

I’m hoping there is some really dumb, small step that I’ve missed here :slight_smile:

Red light indicates no internet connection so strange since it gets an IP from your router. You cant reset it unless you get to the WEB UI unfortunately. I would carry it over to a neighbor and test with router just to be sure. If its still red then I would RMA the Gateway. Sorry, I know its not helpful

1 Like

I am having the same issue. Is this just a very bad and not thought out bit of hardware. Is it best to just take it back to the shop and advise them not to sell anymore?