How to factory reset match X gateway

Just changed the settings of the gateway to client mode and now I can’t seem to be able to communicate with it. It lost communication with the router I had it connected to and now it doesn’t assign an IP address on it. Any idea how to reset the gateway to default settings or hard reset?

Can you describe exactly what you did? Can you connect to the WiFi of the GW? does the GW connect to internet through Etherent? Can you see it connected on the Cloud server?

All I did was change the mode tab to client instead of DHCP and then it just lost connection. –

  • The wireless ESSID does not broadcast anymore
  • The connectivity LED goes red therefore I assume it does not have a connection to anything
  • I checked the modem that I was using, to see if any client IP was assigned to the Match Box but once again nothing.
  • I tried to talk to it through the LAN port on the POE injector and it does not assign me any IP from the gateway. Its last knows LAN IP was 192.168.100.1 and I changed my adaptor to be in the same subnet and I cannot ping it or get a gateway IP assignment.

I am sure there is a way to just reset the gateway back to factory reset and just start again right?

I’ve read through your documentation and you seem to have a reset button on the development board I am sure the gateway has something similar, otherwise is there anything can be done using the type-c connector?

The GW will not assign you a IP when connecting with LAN, you should connect it to some router where the router will assign the IP address to it. If you connect it to the router with Eth can you see it when you scan the network?

The GW can only be reset to default from its webUI, so you need to first login, but the reset works only with the newest 0.0.12 firmware version - does your gateway have most updated firmware?

When you changed to client you probably disabled the AP mode so the GW will not generate SSID anymore.

I’ve tried to connect it to two different routers as mentioned previously the LAN address was set to static 192.168.100.1 not DHCP and I’ve tried modifiying bouth routers gateway address to be in the same subnet to be able to talk to it and it does not get a connection. I’ve even used wireshark to monitor any traffic from the port and the GW does not present any traffic at all.

It does have the latest firmware but I cannot see it on the web UI it just tells me last seen 2 days ago.

Yes correct in client mode its SSID is no longer active hence why I can’t even connect to it over wifi.

So in summary you are suggesting that:

  • Unless the gateway sees an internet connection there is no way of resetting it using any of the USB ports?
  • Even on the PCB there is no reset jumper cable?
  • You can’t re-flash it with new firmware locally other than the webUI

On a side note is the HLK-7688A what needs to be reset or the MCU handles the reset function?

@piotr Any advice as to what to do if I can’t access the GW through any of the network interface? Is there any alternative to at least reset the networking parameters? Is there anything that can be done or is the GW now lost since I can’t reach it?

Hello sebb,

I am sorry but there is no way of resetting the GW without connecting to it somehow, I would assume that at least wired connection should still work. So the router you are using has DHCP server? Can it assign IP address to the GW? If there is no communication at all, you can send the device back to us and we will investigate what has happened.

That’s very unfortunate to hear. Probably a good design suggestion for the next version release. I’ve tried several wired connections through its LAN port. Yes the router had a DHCP server and I’ve tried different types of routers even tried it in different networks and nothing.

Yes that would be appreciated if we can investigate the cause of this issue and possibly get the GW back to a working condition that would be awesome. Can you please advice as to where should I make the request to send the device back and to where does it have to be sent? Thank you.

Hey Sebastian,

I’ve sent the address via email.

Cheers,
Kirill